Alex Dai Playground

[NPM] Windows npm install package , node-gyp rebuild error

| Comments

如果所安裝中的套件有 node-gyp 的依賴關西, 且生發 node-gyp rebuild error 時...

檢查是否已安裝下列工具

解決方法

1.直接帶參數
npm install <package name> --msvs_version=2015 or 其他版本
2.開啟 cmd 設定 evn (關閉cmd,設定就沒了...)
set GYP_MSVS_VERSION=2015
3.使用環境變數 (win10)
  本機(我的電腦)滑鼠右鍵 -> 內容 -> 系統 -> 進階系統設定 -> 環境變數 -> 系統變數
  新增 -> 變數名稱:GYP_MSVS_VERSION, 變數值:2015
4.使用 npm config
npm config set msvs_version 2015 --global
P.S 其他 OS 解決辦法請參閱 https://github.com/nodejs/node-gyp

http://stackoverflow.com/questions/32457761/how-to-solve-node-gyp-rebuild-issue-on-windows-10

Comments

comments powered by Disqus